End of Support for Firefox 1.5

The Mozilla Foundation has announced yesterday that starting April 24th, they would stop supporting all versions of Firefox prior to version 2.0. Still running on version 1.5? Hurry up and upgrade before it’s too late! Here’s a link to the latest version of Firefox bundled with the Google toolbar.


Advertisement





4 Responses to End of Support for Firefox 1.5

  1. I'd upgrade in a flash, but for the stupid way the new version handles tabs, making me chase the to different locations X all over the screen to close them. For someone with a laptop and no mouse who uses tabs a lot, it's a real PITA.

  2. I’d upgrade in a flash, but for the stupid way the new version handles tabs, making me chase the to different locations X all over the screen to close them. For someone with a laptop and no mouse who uses tabs a lot, it’s a real PITA.

  3. @Michael

    If I get you right, you are having trouble closing the tabs, you could use Ctrl+W to close one. I also use All-in-One Gestures add-on and set up a simple gesture to close a tab.

  4. @Michael
    If I get you right, you are having trouble closing the tabs, you could use Ctrl+W to close one. I also use All-in-One Gestures add-on and set up a simple gesture to close a tab.